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1. Member Design as per NTC 2018 

Reference in NTC 2018 Details  

- Add Material of NTC2018 in DShop 

- Add Material of NTC2018 in GSD 

7.4.6.2.2 

[Column] 
Modify the calculation of „Volume of concrete core‟ in Check mechanical volumetric ratio of co
nfining hoops within the critical regions.  

[Wall End] 
Modify the calculation of mechanical volumetric ratio within the critical regions. 

7.4.4.5.1 
1) Shear strength in wall elements under seismic combination is reduced by a 0.4 factor. 
2) Design shear force  of wall elements use the shear force from analysis without any modifica

tion in CD “B”.  

7.4.6.2.2 Minimum mechanical volumetric ratio is considered as 0.12 only for CD"A" in column and wall. 

7.4.4.5.2.2 
In wall element for seismic and non-seismic case, wall length for shear design is calculated by „
d=0.9Lw‟ and „z= 0.8Lw‟ 
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1. Member Design as per NTC 2018 

• Detail Report for Punching Shear Checking as per 6.4.4 and 6.4.5 of EN1992‐1‐1 

   Calculating “Area(Asw) / space(Sr)” of shear reinforcement. 

   as per EN 1992-1-1:2005/A1:2014 

• Update default value and default options 
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The shear span value is user input. 
If it is less than 0, it is treated as an error. 

2. Improvement of post-processing in material nonlinear analysis 

• Strain results are provided for plastic materials, i.e. Tresca, Von Mises, Mohr-Coulomb, Drucker-Prager, and 
Concrete Damage.  

• Damage ratios for compression and tension are  provided for the ‘Concrete Damage’ model. 

Results >  Tables > Results Tables > Plate/ Solid > Strain(local)/ Strain(Global) 

Plate Strain (local) menu Solid Strain (local) menu Plate Strain (local) Table 
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The shear span value is user input. 
If it is less than 0, it is treated as an error. 

Results >  Results > Strains > Plate Strains/ Solid Strains 

2. Improvement of post-processing in concrete damage model 
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The shear span value is user input. 
If it is less than 0, it is treated as an error. 

3. Structure wizard of transmission tower 

• Tower wizard makes it easy to model the leg / body / arm part of a complex 3D tower structure. 

Structure > Wizard > Tower > Tower Leg/ Body/ Arm 



Gen 2019 (v1.1) Release Note midas Gen 

9 

The shear span value is user input. 
If it is less than 0, it is treated as an error. 

• The average and envelope load cases for the time-history load cases are generated in the table. 

• The displacement and the member force are  only supported. 

midas Gen 

4. Improvement of post-processing in time-history analysis results 

Results >  Time History > T.H Results > Time History Load Combination 

Time History 

Load Case 
Result Type Detail 

Added 

nonlinear 

load 

combination 

Cball : TH ENV_User 

input name 

The maximum absolute value among the 

selected load cases 

Cbmax : TH ENV_User 

input name 

The maximum value among the maximum value 

of selected load cases 

Cbmin : TH ENV_User 

input name 

The minimum value among the minimum value 

of selected load cases 

Cbmax : TH AVR_User 

input name 

The average value of the maximum value of 

selected load cases 

Cbmin : TH AVR_User 

input name 

The average value of minimum value of selected 

load cases 

Identical value ! 
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• The  φp value is added  in Torsional Irregularity Check Table as per the Colombia NSR-10 standard. 

• The extreme irregular type is added in Remark field. 

5. Improvement of Torsional Irregularity table 

The shear span value is user input. 
If it is less than 0, it is treated as an error.  

Ø p is the factor regarding the plan irregularity. If the structure has normal 
torsional irregularity (between 1.2 and 1.4) it must use Ø p as 0.9. If the 
structure has extreme torsional irregularity (more than 1.4), Ø p will be 0.8.  
If the structure is regular, Ø p will be 1.0.  

Regular : Story Drift of Maximum Value = 

< 1.2*Story Drift of Average Value of Extreme 

Points 

 

Irregular :  1.2*Story Drift of Average Value of 

Extreme Points < Story Drift of Maximum Value 

=< 1.4*Story Drift of Average Value of Extreme 

Points 

 

Extreme Irregular : 1.4*Story Drift of Average 

Value of Extreme Points < Story Drift of 

Maximum Value 

 
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The shear span value is user input. 
If it is less than 0, it is treated as an error.  

• Response modification factor R is calculated using three reduction factors to consider the irregularity of structure 
as per the Colombia NSR-10 standard.  (R=φa*φp*φr*R0) 

• Height Irregularity (φa), Plan irregularity (φp), Redundancy Check (φr) 

6. Automatic application of reduction factor for irregular structure (NSR-10) 

Calculation sheet of seismic load 
 

Graph of the story force 

Enter the φp obtained from the Torsional Irregularity table. 
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The shear span value is user input. 
If it is less than 0, it is treated as an error.  

• Loading Area Group  can be defined by selecting an area to apply wind pressure . 

7. Definition of Loading Area Group 

Structure >  Group > B/L/T  > Define Loading Area Group 
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The shear span value is user input. 
If it is less than 0, it is treated as an error.  

• Wind load is applied on the space structure according to user-defined function. 

• Wind load is applied as the nodal load on the nodes compsing the defined loding area. 

8. Wind pressure function 

Load > Static Load > Lateral > Wind Pressure  

Input Equation for Function 

 Wind Pressure Function   Function Wind Pressure 
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• TRC dampers manufactured by Sumitomo Riko Company Limited is added to the viscoelastic material properties. 

The shear span value is user input. 
If it is less than 0, it is treated as an error.  

9. Improvement of viscoelastic damper 

4 element model 

Viscoelastic material properties TRC Damper 

Bilinear of K2 

Shear strain dependence 
of K1, C1 and C2 

Mount 

4 element model 

Boundary > General Link > Seismic Device Properties... > Viscoelastic Damper 
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The shear span value is user input. 
If it is less than 0, it is treated as an error.  

9. Improvement of viscoelastic damper 

Boundary > General Link > Seismic Device Properties... > Viscoelastic Damper 

TRC  Damper  (4 element model) 

Compression with other products 

- Input seismic wave 

: Total Components（K1(Maxwell)＋K2(Voigt)＋C1(Maxwell)＋C2(Voigt)）+  Mount 

- Verification model 

-1.E+05

-8.E+04

-6.E+04

-4.E+04

-2.E+04

0.E+00

2.E+04

4.E+04

6.E+04

8.E+04

1.E+05

-1.0 -0.8 -0.6 -0.4 -0.2 0.0 0.2 0.4 0.6 0.8 1.0

GEN

SNAP(Product A) 

- Compression of historical loop 

(MIDAS) 

Mass = 5102.04 N/g 
Elastic Stiffness = 10000 N/m 
Undamped System 
Mounting Stiffness = 1000000 N/m 
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The shear span value is user input. 
If it is less than 0, it is treated as an error.  

9. Improvement of viscoelastic damper 

Boundary > General Link > Seismic Device Properties... > Viscoelastic Damper 

TRC  Damper  (4 element model) 

Compression with other products 

: Total Components（K1(Maxwell)＋K2(Voigt)＋C1(Maxwell)＋C2(Voigt)）+  Mount 

(Historical loop) 

-8.E+04

-6.E+04

-4.E+04
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(Product A) 

(MIDAS) 

(Product A) 

(MIDAS) 

(Product A) 

(MIDAS) 
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The shear span value is user input. 
If it is less than 0, it is treated as an error.  

• Print out  energy results graph for isolator and vibration control device in the nonlinear time history analysis. 

10. Addition of Energy Result Graph 

Result > T.H Graph/Text > Time History Energy Graph 

 A S HE E E
SE HE

 A S HE E E

HE

SE
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The shear span value is user input. 
If it is less than 0, it is treated as an error.  

10. Addition of Energy Result Graph 

Result > T.H Graph/Text > Time History Energy Graph 
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The shear span value is user input. 
If it is less than 0, it is treated as an error.  

10. Addition of Energy Result Graph 

Result > T.H Graph/Text > Time History Energy Graph 

Text result of the each energy ratio 
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The shear span value is user input. 
If it is less than 0, it is treated as an error.  

10. Addition of Energy Result Graph 

Result > T.H Graph/Text > Time History Energy Graph 

StrtGrp 1F StrtGrp 2F StrtGrp 3F 

BndrGrp 1 BndrGrp 2 BndrGrp 3 Result output  of group distribution for each energy item 
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The shear span value is user input. 
If it is less than 0, it is treated as an error.  

• Reactions from Point Spring Support can be exported to GTS NX. 

• Force-displacement results  of soil can be imported from GTS NX into midas Gen, and the input data of the multi-linear 
Point Spring Supports are updated. 

File > Export > Nodal Results for GTS 

File > Import > Nodal Results for GTS 

 

Reactions 
Spring 

Data 

11. Multi-linear type elastic spring/ link for interface with GTS NX 
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The shear span value is user input. 
If it is less than 0, it is treated as an error.  

• Multiple linear type elastic springs are defined as functions without limitation. 

12. Multi-linear force-deformation function for Point Spring Support and Elastic Link 

Multi-linear is defined 
as 6 points in the 
previous version. 

 Previous version  Gen 2019 (v1.1)  
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The shear span value is user input. 
If it is less than 0, it is treated as an error.  

Pushover Global Control Pushover Analysis for the underground structure 

13. Nonlinear Elastic Links for Pushover Analysis 

• Nonlinear behavior of the elastic links, i.e. comp.-only, tens.-only, multi-linear can be taken into account in the 
pushover analysis. 

• Link forces imported from static analysis or construction stage analysis cannot be specified as initial loads for 
pushover analysis. 

Pushover > Elements > Pushover Global Control 

Bi-linear 
Elastic Links 
representing  
soil resistance 
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The shear span value is user input. 
If it is less than 0, it is treated as an error.  

• Tekla Structures interface is a tool provided to speed up the entire modeling, analysis, and design procedure of a 
structure by data transfer with midas Gen. Data transfer is limited to structural elements. Tekla Structure interface 
enables us to transfer a Tekla model data to midas Gen, and  delivery back to the Tekla model file. midas Gen text 
file (*.mgt) is used for the roundtrip.  

 

14. Tekla Structure 2018 Interface 

File > Import > midas Gen MGT File 

File > Export > midas Gen MGT File 

Category Features Tekla <> Gen 

MATERIAL 

concrete <> 

steel <> 

pre cast - wood and other types <> 

Material user defined <> 

ELEMENT TYPE/ 

ROTATIONS 

vertical column <> 

inclined column <> 

straight beam <> 

curved beam > 

Slab <> 

vertical panel > 

2D ELEMENTS Concrete panels and slab <> 

BOUNDARY CONDITIONS 

support > 

beam end release <> 

section offset > 

STATIC LOAD 

self weigth > 

linear load 

 (uniform or trapezoidal) 
<> 

MERGE OPTION 

new element <> 

new element that 

 divide other elements 
<> 

topology changes <> 

Tekla Structure 2018 

Gen 2019 
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The shear span value is user input. 
If it is less than 0, it is treated as an error.  

• Reinforcement as per Singapore SS560:2010 is added for the design. 

15. Reinforcement as per SS560 : 2010 

Tools > Setting > Preferences Design > Design> RC Design > Design Criteria for Rebar 
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midas Design+ 
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The shear span value is user input. 
If it is less than 0, it is treated as an error.  

• The automatic design / check of the SRC column is performed as per AISC-LRFD 10M. 

1. SRC Column 

↓ Drawing 



28 

midas Design+ Design+ 2019 (v1.1) Release Note Design+ 2019 (v1.1) Release Note midas Design+ 

The shear span value is user input. 
If it is less than 0, it is treated as an error.  

2. CFT Column 

↓ Summary report 

Detail report → 

• The automatic design / check of the CFT column is performed as per AISC-LRFD 10M. 
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The shear span value is user input. 
If it is less than 0, it is treated as an error.  

• Reinforced concrete beam strengthened with FRP / carbon fiber is automatically designed or checked. 

• ACI318-08/11/14, ACI318M-08/11/14, NSR-10, and KCI-USD07/12 are supported. 

3. Carbon fiber strengthened beam 

Flow chart of neutral axis calculation 

Calculation of neutral axis 

Assumption of  neutral 
axis initial value (0.2𝑑) 

Calculation of initial strain (𝜀𝑏𝑖) 

Calculate of design strain (𝜀𝑓𝑑)  

Calculation of effective strain (𝜀𝑓𝑒) 

Calculation of concrete strain (𝜀c) 

Calculation of the steel strain & stress (𝜀s, 𝑓s)  

Calculation of carbon fiber stress ( 𝑓𝑓𝑒) 

𝐹𝑠+𝐹𝑓=𝐹𝑐 

Calculation of Flexural strength  
( 𝑀𝑛𝑠, 𝑀𝑛𝑓, 𝜙𝑀𝑛) 

End of neutral axis calculation 

Yes 

No 
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 H형강  T형강  L형강  C형강  각형 강관  원형 강관  Solid Round  
Solid Box 

• The aluminum beam / column design check is based on the Aluminum Design Manual (ADM1:2005) of AA 
(Aluminum Associate, USA).  

• The automatic check of the aluminum beam / column is performed as per AISC-LRFD 10M. 

 

4. Aluminum beam/column 

< Design Code > 

AA-ASD05 
AA-ASD05M   
AA-LRFD05 
AA-LRFD05M 

< Shape of Section> 

Beam/ Column 
H Section 
T Section 
Angle 
Channel 
Box 
Pipe 
Solid Round 
Solid Box 
 
Beam/ Column(General) 
IJ-7781 
IJ-8382 
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The shear span value is user input. 
If it is less than 0, it is treated as an error.  

• When the rib plate is inserted in the baseplate and the length of the rib plate is larger than 1/2 of the thickness of 
the base plate, the rib plate is created on the flange of the column. 

• AISC-LRFD 10, ASIC-LRFD 05, Eurocode3:05, KSSC-LSD 16, and KSSC-LSD 09 are supported. 

5. Improvement of Rib plate for base plate 


